Princípios II - Laboratório

índice da matéria

programa 9

página inicial

/* Sabe-se que dois vetores V e W sao ortogonais se a soma dos produtos dos elementos V[I] e W[I] for igual a zero. Fazer um programa que a partir da entrada dos dois vetores (tres elementos cada um) determine se os mesmos sao ortogonais e imprime a mensagem adequada.

Inicio
    inteiro:I;
    real:prod_esc;
    real:V[i],W[I];
    prod_esc <- 0;
    para I de 1 ate 3 passo 1 faca
        leia (V[I],W[I]);
        prod_esc <- prd_esc + V[I]*W[I];
    fim para
    se (prod_esc=0)
        entao
            escreva ("Os vetores V e W sao ortogonais");
        senao
            escreva ("Os vetores V e W nao sao ortogonais")
    fim se
fim
--> programa em 18/10/2002*/
--> programa em 18/10/2002*/
#include<iostream.h>
void main()
{
    int I;
    float prod_esc;
    float V[3],W[3];
    prod_esc=0;
    cout<<"+----------------------------------------------------------+\n";
    cout<<"| Programa que le dois vetores de tres elementos cada um |\n";
    cout<<"| e informa se os mesmos sao ortogonais, ou seja, se a |\n";
    cout<<"| soma dos produtos de seus elementos e' igual a zero. |\n";
    cout<<"| Exemplo de vetores ortogonais: (1,2,3) e (1,-2,1) |\n";
    cout<<"+----------------------------------------------------------+\n\n";

//------------ entrada dos elementos dos vetores --------------

    cout<<"Entre com os elementos do primeiro vetor:\n";
    for (I=1;I<=3;I++)
    {
        cout<<"Elemento ["<<I<<"]: ";cin>>V[I];
    }
    cout<<"\nEntre com os elementos do segundo vetor:\n";
    for (I=1;I<=3;I++)
    {
        cout<<"Elemento ["<<I<<"]: ";cin>>W[I];
    }

//------------ calculo do produto escalar ---------------------

    for (I=1;I<=3;I++)
    {
        prod_esc=prod_esc+V[I]*W[I];
    }

//------------ verifica o resultado e mostra a mensagem -------

    if (prod_esc!=0)//-> foi trocada a ordem em relacao ao algoritmo
    {
        cout<<"\nValor do produto escalar: "<<prod_esc<<"\n";
        cout<<"\nOs vetores V e W nao sao ortogonais.";
    }
    else
    {
        cout<<"\nValor do produto escalar: "<<prod_esc<<"\n";
        cout<<"\nOs vetores V e W sao ortogonais.";
    }
} // fim do programa
Sobre as linhas de código acima - para download:
programa compilado: Prog9.exe   -   código-fonte: Prog9.cpp
(O arquivo .cpp é um arquivo tipo texto que pode ser aberto e impresso pelo wordpad ou notepad)

imagem do programa:

índice da matéria

programa 9

página inicial