Princípios II - Laboratório

índice da matéria

programa 8

página inicial

/*Programa 23 - 04/10/02 - Soma dos elementos da diagonal de uma matriz quadrada.
Elaborar um programa que permita ler uma matriz quadrada m_quad de dimensoes quaisquer e que calcule e escreva a soma dos elementos da diagonal.

Assunto: estruturas de dados homogeneas (matrizes), de repeticao (com variavel de controle)

Metodo computacional:
1) Dados de entrada:
- numero N de linhas e de colunas da matriz m_quad;
- elementos desta matriz;
2) Processamento:
- inicializacao da soma_diag;
- uso de uma estrutura de repeticao ´para´
- fim para entrar os elementos por linha;
- uso de uma estrutura de repeticao ´para´
- fim para entrar os elementos por coluna;
- entrada elemento por elemento;
- soma do elemento da diagonal para a linha considerada
3) Dados de saida: soma_diag;

Algoritmo:
Inicio
tipo: quadrada=matriz[1..10,1..10] de reais;
inteiro: i,j,n;
real: soma_diag;
quadrada: m_quad;
soma_diag <-- 0;
leia (n);
   para i de 1 ate n passo 1 faca
      para j de 1 ate n passo 1 faca
         leia (m_quad[i,j]);
      fim para
      soma_diag <-- soma_diag + m_quad[i,i];
   fim para
escreva (soma_diag);
fim*/

#include<iostream.h>
void main()
{
    int i,j,n,espera;
    float soma_diag;
    float m_quad[11][11];
    soma_diag=0;
    cout<<"** Programa para leitura de uma matriz quadrada **\n";
    cout<<"** e calculo da soma dos elementos de sua diagonal **\n\n";
    cout<<"Entre com o numero de linhas e colunas: ";
    cin>>n;
    for (i=1;i<=n;i++)
    {
        for (j=1;j<=n;j++)
        {
            cout<<"\tEntre com o valor do elemento ["<<i<<"]["<<j<<"]: ";
            cin>>m_quad[i][j];
        }
        soma_diag+=m_quad[i][i];
    }
    cout<<"\nResultado da soma dos elementos da diagonal: "<<soma_diag;
    cin>>espera;
}//fim do programa 
Sobre as linhas de código acima - para download:
programa compilado: Prog8.exe   -   código-fonte: Prog8.cpp
(O arquivo .cpp é um arquivo tipo texto que pode ser aberto e impresso pelo wordpad ou notepad)
índice da matéria

programa 8

página inicial